Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Edublogs (sites.gsu.edu) Issues Reported
Incident Report for GSU Technology Systems
Resolved
Edublog vendors were able to successfully resolve the outstanding issue with sites.gsu.edu. Please contact IS&T Help Center at help@gsu.edu or 404-413-4357(HELP) to report any additional questions or concerns.
Posted Aug 24, 2015 - 11:05 EDT
Investigating
IS&T is currently investigating reports of problems with sites.gsu.edu and users are not able to access their sites. Engineers are working with vendor to resolve the issue. Additional information will be posted here when the issue is confirmed.
Posted Aug 24, 2015 - 09:09 EDT