Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
gsu.edu is currently unavailable
Incident Report for GSU Technology Systems
Resolved
Issues reported earlier with GSU.edu have successfully been resolved. If you are still experiencing problems with GSU.edu, then please contact IS&T Help Center at help@gsu.edu or call 404-413-4357(Help).
Posted Mar 05, 2015 - 16:17 EST
Monitoring
GSU.edu is currently available and is being monitored.
Posted Mar 05, 2015 - 15:20 EST
Identified
GSU.edu is currently unavailable. Technicians are working to restore these services shortly.  Any updates to this issue will be posted at status.gsu.edu.
Posted Mar 05, 2015 - 14:41 EST