Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Microsoft Outlook Distribution Group issue
Incident Report for GSU Technology Systems
Resolved
Microsoft has resolved the outlook distribution group issue, deployed the fix and verified the service is restored. Please contact IS&T Help Center to report any additional issues at 404-413-4357(HELP) or email help@gsu.edu.
Posted Jun 01, 2015 - 09:48 EDT
Identified
Microsoft is investigating reports from users that are unable to add users to Distribution Groups from within the Outlook Client. As a workaround, users are asked to add users to Distribution Groups using Outlook Web App(OWA). More information will be provided here when an update is given.
Posted May 27, 2015 - 16:26 EDT