Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Dunwoody Campus Power Outage
Incident Report for GSU Technology Systems
Resolved
Power has been restored to Dunwoody Campus. Please contact IIT Technology Service Desk by email at help@gsu.edu or call 404-413-4357(HELP) to report any additional problems with Dunwoody Power Outage Event
Posted Jul 29, 2016 - 09:32 EDT
Monitoring
Power has been restored to Dunwoody Campus and our teams will continue to monitor this event throughout the day. Please contact IIT Technology Service Desk by email at help@gsu.edu or call 404-413-4357(HELP) to report any additional problems with Dunwoody Power Outage Event.
Posted Jul 28, 2016 - 10:55 EDT
Identified
A power outage has been reported on Dunwoody Campus. Georgia Power is reporting that the power outage is due to a fallen tree and is working to restore power. More updates will be posted as they become available.
Posted Jul 28, 2016 - 09:27 EDT