Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Power event in multiple campus buildings
Incident Report for GSU Technology Systems
Resolved
On Tuesday August 18 at approximately 6:44pm, multiple GSU campus buildings experienced a utility power failure, affecting some network services. Utility power has since been restored and network services have returned to normal, IS&T will now close this incident as all systems are running as expected.
Posted Aug 19, 2015 - 16:55 EDT
Monitoring
This evening at approximately 6:44pm multiple GSU campus buildings experienced a utility power failure, effecting some network services. While utility power has been restored and network services have returned to normal, IS&T will continue to monitor the situation for any failures resulting from the outage.
Posted Aug 18, 2015 - 19:24 EDT