Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
iCollege Issue Reported
Incident Report for GSU Technology Systems
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 07, 2019 - 09:32 EST
Update
We are continuing to monitor for any further issues.
Posted 2 months ago. Feb 07, 2019 - 09:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Feb 07, 2019 - 08:55 EST
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with logging onto iCollege. Additional information will be posted here when the issue is confirmed.
Posted 2 months ago. Feb 07, 2019 - 07:45 EST
This incident affected: Brightspace/iCollege.