Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Telephone Issues Reported
Incident Report for GSU Technology Systems
Resolved
Issue has been resolved. If further assistance is needed, please contact the IIT Technology Service Desk.
Posted Jan 18, 2017 - 16:06 EST
Monitoring
The University is currently experiencing extremely high call volume and some users are reporting they are receiving busy signals and dropped calls. IIT is currently monitoring the situation and making adjustments as appropriate.

We encourage all Faculty & staff to review and use dialing plan below that can now be used to contact all departments and reach out to colleagues across campuses. This will help us keep our phone lines open for Students and other calls from off campus.

The dialing plan is as follows:
Perimeter Campus locations to Downtown Campus: Dial 84 + last 5 digits of phone number: 84-xxxxx
Downtown Campus to Perimeter Campuses: Dial 6 + last 4 digits of phone number: 6-xxxx
Posted Jan 04, 2017 - 13:17 EST