Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Kivuto (gsu.onthehub.com) Incident Reported
Incident Report for GSU Technology Systems
Resolved
IS&T resolved the issue that some users were experiencing with Kivuto (gsu.onthehub.com) where software was not able to be added to the cart. Please contact IS&T Help Center by phone 404-413-4357(Help) or email help@gsu.edu to report any additional problems.
Posted Nov 25, 2014 - 15:40 EST
Investigating
IS&T is currently investigating reports of an issue with Kivuto (gsu.onthehub.com). Reports are being received that users are unable to download software from the site due to their eligibility being expired when clicking on Add To Cart. Additional information will be posted here when the issue is confirmed.
Posted Nov 25, 2014 - 14:06 EST