Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Inbound Call Issues - Downtown Campus
Incident Report for GSU Technology Systems
Resolved
Issue has been resolved
Posted Sep 25, 2020 - 08:30 EDT
Monitoring
A fix has been implemented and we will continue to monitor.
Posted Sep 25, 2020 - 08:12 EDT
Investigating
Instructional Innovation and Technology (IIT) is investigating reports of issues with inbound calls to some Downtown Campus Atlanta 404-413-xxxx numbers. Internal and outbound calls are not affected. IIT Network Engineering will share additional details as they become available.
Posted Sep 24, 2020 - 16:15 EDT
This incident affected: Telephone System.