Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU.EDU Website Inaccessibility
Incident Report for GSU Technology Systems
Resolved
IIT resolved issues with accessing GSU.edu. If you experience issues, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help.gsu.edu.
Posted about 1 month ago. Jun 10, 2019 - 08:24 EDT
Investigating
Instructional Innovation and Technology (IIT) are currently investigating issues with accessing gsu.edu. Our service providers are working on restoring access to the website. Updates will be posted as they become available.
Posted about 2 months ago. Jun 08, 2019 - 18:45 EDT
This incident affected: University Website.