Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
iCollege My Courses Not Loading
Incident Report for GSU Technology Systems
Resolved
After monitoring, this issue has not reoccurred. If you do see any additional iCollege issues, please contact help@gsu.edu.
Posted Sep 14, 2020 - 09:16 EDT
Monitoring
The issues affecting the My Courses widget have been resolved. We are continuing to monitor for further issues.

Please contact help@gsu.edu if you do experience additional problems with iCollege.
Posted Sep 11, 2020 - 14:49 EDT
Investigating
We are receiving reports of issues with the My Courses widget on the iCollege homepage not loading correctly. We are currently investigating the issue with the vendor.

Courses are still available in the "waffle" menu at the top of the iCollege homepage.
Posted Sep 11, 2020 - 13:00 EDT
This incident affected: Brightspace/iCollege.