Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
O365 Staff Login
Incident Report for GSU Technology Systems
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 11:11 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 14, 2022 - 12:03 EDT
Monitoring
A fix has been implemented and we will continue to monitor results
Posted Aug 14, 2022 - 12:02 EDT
Investigating
Instructional Innovation & Technology (IIT) is currently investigating a site certificate issue when attempting to access staff email. Engineers are currently working to update the certificate. This should only impact new authentications to the site. Updates will be provided once available.
Posted Aug 14, 2022 - 09:29 EDT
This incident affected: Office 365 (Fac/Staff Email).