Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Wireless Issues
Incident Report for GSU Technology Systems
Resolved
IIT has resolved GSU wireless issues on Downtown and PC campuses.
Posted 2 months ago. May 21, 2019 - 11:31 EDT
Monitoring
Instructional Innovation and Technology (IIT) resolved GSU wireless issues on Downtown and PC campuses. We will continue to monitor. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted 2 months ago. May 19, 2019 - 11:01 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating GSU wireless issues on Downtown and PC campuses. Updates will be posted as they become available.
Posted 2 months ago. May 18, 2019 - 16:50 EDT
This incident affected: Campus Wireless Network.