Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
DegreeWorks Issue Reported
Incident Report for GSU Technology Systems
Resolved
IIT resolved the issue with DegreeWorks. Users should now be able to access DegreeWorks and academic evaluations successfully. Please contact IIT Technology Service Desk to report any additional problems at 404-413-4357(HELP) or email help@gsu.edu.
Posted Dec 08, 2016 - 08:46 EST
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of an issue with DegreeWorks. Users will see a blank page as they attempt to access DegreeWorks. Additional information will be posted here when the issue is confirmed.
Posted Dec 08, 2016 - 08:15 EST