Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
WordPress Admin Login Unavailable
Incident Report for GSU Technology Systems
Resolved
IIT was able to work with vendor to resolve the issue. Please contact IIT Technology Service Desk to report any additional issue at 404-413-4357(HELP) or email help@gsu.edu.
Posted Mar 23, 2017 - 08:05 EDT
Monitoring
IIT was able to work with vendor to resolve the issue. We will continue to monitor throughout the day. Please contact IIT Technology Service Desk to report any additional issue at 404-413-4357(HELP) or email help@gsu.edu.
Posted Mar 22, 2017 - 14:56 EDT
Investigating
WordPress admin is currently unavailable and issue has been identified. IIT is working on a resolution. Please continue to check status page for any updates.
Posted Mar 22, 2017 - 10:12 EDT