Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Website Issues Reported(10/10)
Incident Report for GSU Technology Systems
Resolved
IIT resolved the issue reported with GSU websites. Please contact IIT Technology Service Desk at 404-413-4357(HELP) or email help@gsu.edu to report any additional issues.
Posted 2 months ago. Oct 12, 2018 - 15:13 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with GSU Websites. Additional information will be posted here when the issue is confirmed.
Posted 2 months ago. Oct 10, 2018 - 12:33 EDT
This incident affected: University Website.