Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Website Issues Reported
Incident Report for GSU Technology Systems
Resolved
IIT has successfully applied a fix and resolved issues with GSU Websites. Please contact IIT Technology Service Desk to report any additional technical issues at 404-413-4357(HELP) or email help@gsu.edu.
Posted 5 months ago. Dec 05, 2018 - 07:50 EST
Monitoring
IIT has successfully applied a fix and are now monitoring the GSU websites. Please contact IIT Technology Service Desk to report any additional technical issues at 404-413-4357(HELP) or email help@gsu.edu.
Posted 5 months ago. Dec 04, 2018 - 12:07 EST
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with GSU Websites. Additional information will be posted here when the issue is confirmed.
Posted 5 months ago. Dec 04, 2018 - 11:17 EST
This incident affected: University Website.