Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
WordPress Page(Admin) Issues Reported
Incident Report for GSU Technology Systems
Resolved
There have been no new reports related to this incident. Please contact IIT Technology Service Desk by phone at 404-413-4357(HELP) or email help@gsu.edu to report any additional questions or concerns.
Posted Aug 09, 2017 - 08:16 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with WordPress. Admins are not able to properly perform administrative functions on WordPress pages. Additional information will be posted here when the issue is confirmed.
Posted Aug 08, 2017 - 11:07 EDT