Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
PantherMail Issues Reported
Incident Report for GSU Technology Systems
Resolved
IIT worked with Microsoft and resolve the panthermail issues reported on Friday-April 28th. Please contact IIT Service Desk at help@gsu.edu or contact 404-413-4357(HELP) to report any additional issues.
Posted May 01, 2017 - 07:37 EDT
Monitoring
IIT worked with Microsoft to resolve the panthermail issues reported. We will continue to monitor the issue for the next 24 hours. Please contact IIT Service Desk at help@gsu.edu or contact 404-413-4357(HELP) to report any additional issues.
Posted Apr 28, 2017 - 09:34 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of an issue with PantherMail (Student Email). Additional information will be posted here when the issue is confirmed.
Posted Apr 28, 2017 - 07:40 EDT