Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Network Issues-Lakeside
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved network issues on the Lakeside campus. If you continue to experience issues, please contact the Technology Service Desk at 404-413-4357 or email help@gsu.edu
Posted Mar 19, 2018 - 09:56 EDT
Update
Instructional Innovation and Technology (IIT) continues to investigate network issues on the Lakeside campus. We will provide more updates when available. If you have questions or concerns, please contact the Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted Mar 07, 2018 - 09:46 EST
Investigating
Instructional Innovation and Technology (IIT) is currently investigating network issues on the Lakeside campus. We will provide more updates when available. If you have questions or concerns, please contact the Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted Mar 06, 2018 - 14:49 EST