Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Decatur Campus Delayed Opening - Power Outage
Incident Report for GSU Technology Systems
Resolved
Campus has opened successfully with no issues reported. Status is resolved. Please contact IIT Technology Service Desk at 404-413-4357(help) or email help@gsu.edu to report any developing issues.
Posted 2 months ago. Sep 13, 2017 - 13:34 EDT
Update
Decatur Campus power has been restored and the campus returned to service. It is scheduled to open at noon today under normal operation. Please contact IIT Technology Service Desk at 404-413-4357(help) or email help@gsu.edu to report any issues or concerns.
Posted 2 months ago. Sep 13, 2017 - 07:55 EDT
Identified
Decatur Campus will remain closed until noon due to power outage associated with tropical storm Irma. Students, faculty and staff at Decatur will be updated of any status changes.
Posted 2 months ago. Sep 12, 2017 - 21:39 EDT