Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Send-A-File Issues Reported
Incident Report for GSU Technology Systems
Resolved
Issues reported earlier with Send-A-File (sendafile.gsu.edu) have successfully been resolved. If you are still experiencing problems with Send-A-File, then please contact IS&T Help Center at help@gsu.edu or call 404-413-4357(Help).
Posted Feb 26, 2015 - 13:04 EST
Identified
IS&T has identified an issue with Send-A-File (sendafile.gsu.edu) and is currently working to resolve it. Additional information will be posted here as it becomes available.
Posted Feb 26, 2015 - 12:30 EST