Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Lynda.com Issues Reported
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved Lynda.com access issues.
Posted 2 months ago. Oct 02, 2017 - 20:18 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of an issue with Lynda.com. Additional information will be posted here when the issue is confirmed.
Posted 2 months ago. Oct 02, 2017 - 07:44 EDT