Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
High Call Volume Phone Issue
Incident Report for GSU Technology Systems
Resolved
IIT resolved the issue with high call volume issue on our telephone lines. Please contact IIT Technology Service Desk by email at help@gsu.edu or call 404-413-4357(HELP) to report any additional problems.
Posted Aug 23, 2016 - 08:26 EDT
Monitoring
The University is currently experiencing extremely high call volume this morning and some users are reporting they are receiving busy signals. IIT is currently monitoring the situation and adjusting numbers, as appropriate.

We encourage all Faculty & staff to review and use dialing plan below that can now be used to contact all departments and reach out to colleagues across campuses. This will help us keep our phone lines open for Students and other calls from off campus.
Posted Aug 16, 2016 - 12:06 EDT
Identified
The University is currently experiencing extremely high call volume this morning and some users are reporting they are receiving busy signals. IIT is currently monitoring the situation and adjusting numbers, as appropriate.

We encourage all Faculty & staff to review and use dialing plan below that can now be used to contact all departments and reach out to colleagues across campuses. This will help us keep our phone lines open for Students and other calls from off campus.

The dialing plan is as follows:
Perimeter Campuseses to Downtown Campus: Dial 84 + last 5 digits of phone number: 84-xxxxx
Downtown Campus to Perimeter Campuses: Dial 6 + last 4 digits of phone number: 6-xxxx
Posted Aug 15, 2016 - 10:51 EDT