Report an issue at: IS&T Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Website Issues Reported
Incident Report for GSU Technology Systems
Resolved
GSU websites are back to normal operation. Please contact IS&T Help Center by phone 404-413-4357(help) or email help@gsu.edu to report any additional problems.
Posted almost 2 years ago. Apr 30, 2014 - 15:09 EDT
Investigating
IS&T is currently investigating reports of issues with GSU Websites which includes but not limited to missing pictures and links not properly working. Additional information will be posted here when the issue is confirmed.
Posted almost 2 years ago. Apr 30, 2014 - 14:21 EDT