Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Pharos Web Release Problem
Incident Report for GSU Technology Systems
Resolved
Patrons are now able to use Pharos Web Release (mobileprint.gsu.edu) when printing multiple copies and will be properly charged for the number of pages printed. Please contact IS&T Help Center by email help@gsu.edu or 404-413-4357(HELP) to report any additional problems or concerns.
Posted Oct 23, 2014 - 09:20 EDT
Identified
At this time, IS&T is requesting for patrons to not use Pharos Web Release (mobileprint.gsu.edu) when printing multiple copies. The user will not be charged correctly for those multiple prints.

Pharos is currently working with IS&T to resolve the issue. Additional updates will be posted here once issue is resolved.
Posted Oct 22, 2014 - 12:19 EDT