Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
calendar.gsu.edu Issue Reported
Incident Report for GSU Technology Systems
Resolved
Issues reported earlier with calendar.gsu.edu have successfully been resolved. If you are still experiencing problems with calendar.gsu.edu, then please contact IS&T Help Center at help@gsu.edu or call 404-413-4357(Help).
Posted May 15, 2015 - 15:36 EDT
Investigating
IS&T is currently investigating reports of an issue with calendar.gsu.edu. Additional information will be posted here when the issue is confirmed.
Posted May 15, 2015 - 09:52 EDT