Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
There has been a power outage at the Clarkston Campus, IIT Engineers are on the way there, and facilities is being contacted.
Incident Report for GSU Technology Systems
Resolved
Power has been restored to Clarkston Campus. If you experience any additional problems, please contact the IIT Technology Service Desk at 404-413-HELP (404-413-4357) or by email at help@gsu.edu
Posted Jul 14, 2016 - 14:31 EDT
Monitoring
IIT Engineers have identified a resolution and are monitoring.
Posted Jul 12, 2016 - 02:20 EDT
Investigating
IIT Engineers are currently investigating this issue.
Posted Jul 11, 2016 - 23:30 EDT