Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Single Sign-on Issue Reported
Incident Report for GSU Technology Systems
Resolved
IIT was able to resolve the reported problems of logging onto iCollege, PAWS and other applications. Please contact IIT Service Desk to report any additional concerns or issues by email help@gsu.edu or contact 404-413-4357(HELP).
Posted Nov 30, 2016 - 07:38 EST
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with logging onto iCollege, Paws and other single sign on applications. Additional information will be posted here when the issue is confirmed.
Posted Nov 29, 2016 - 20:27 EST