Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
OneDrive Service Issue
Incident Report for GSU Technology Systems
Resolved
Microsoft resolved issues reported with OneDrive. Please contact IIT Technology Service Desk to report any additional issues at help@gsu.edu or contact 404-413-4357(Help).
Posted May 09, 2017 - 09:34 EDT
Investigating
IIT is currently investigating reports of OneDrive service synchronization and access issues. Please continue to check here for additional updates.
Posted Apr 27, 2017 - 15:49 EDT