Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Decatur Campus Power Outage
Incident Report for GSU Technology Systems
Resolved
IIT resolved the Decatur Campus power outage. Please contact IIT Technology Service Desk by email at help@gsu.edu or call 404-413-4357(HELP) to report any additional problems.
Posted Nov 26, 2016 - 10:02 EST
Monitoring
Power has been restored to the Decatur Campus. IIT Network Operations staff will continue to monitor the situation throughout the day. Please contact the IIT Service Desk by email at help@gsu.edu or contact 404-413-4357(HELP) to report any additional problems or concerns.
Posted Nov 24, 2016 - 09:13 EST
Update
The power outage is still ongoing. Georgia Power is estimating that power will be restored at 8:45 AM. Public Safety says there is no impact as the campus facilities are closed for the holiday. More updates will posted here as they become available.
Posted Nov 24, 2016 - 08:25 EST
Update
Georgia Power is actively working to restore power. They estimate power will be restored by 7:30 AM.
Posted Nov 24, 2016 - 07:21 EST
Identified
A power outage has been reported on Decatur Campus. Public Safety has contacted Georgia Power. More updates will be posted as they become available.
Posted Nov 24, 2016 - 06:50 EST