Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Numara Issues Reported
Incident Report for GSU Technology Systems
Resolved
Numara is now operational. Please contact IS&T Help Center at 404-413-4357(HELP) or email help@gsu.edu to report any additional problems or concerns
Posted Jun 19, 2015 - 10:50 EDT
Investigating
IS&T is currently investigating reports of issues with Numara. Additional information will be posted here when the issue is confirmed.
Posted Jun 19, 2015 - 10:19 EDT