Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Degree Works/Academic Evaluation Incident Reported
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved the issue with Degree Works/Academic Evaluation. If you are still experiencing issues with Degree Works/Academic Evaluation, please contact the Instructional Innovation and Technology (IIT) Service Desk by phone at 404-413-HELP (404-413-4357) or by email at help@gsu.edu.
Posted Feb 11, 2016 - 18:07 EST
Monitoring
Instructional Innovation and Technology (IIT) has resolved the issue with Degree Works/Academic Evaluation and will continue to monitor the system. If you are still experiencing issues with Degree Works/Academic Evaluation, please contact the Instructional Innovation and Technology (IIT) Service Desk by phone at 404-413-HELP (404-413-4357) or by email at help@gsu.edu.
Posted Feb 09, 2016 - 20:57 EST
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of an issue with Degree Works/Academic Evaluation. Users are experiencing issues when trying to access their information. Additional information will be posted here as it becomes available.
Posted Feb 09, 2016 - 16:30 EST