Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
iRIS/IRB login issues
Incident Report for GSU Technology Systems
Resolved
The issues with iRIS/IRB Wise have been resolved. Users should now be able to log in to the application again. If you are still having an issue, please contact the IS&T Help Center at 404-413-4357
Posted Apr 02, 2014 - 11:49 EDT
Investigating
IS&T is currently investigating reports of an issue with iRIS/IRB Wise, users are unable to log in to the application. Additional information will be posted here when the issue is confirmed.
Posted Apr 02, 2014 - 10:03 EDT