Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Inclement weather moving through Atlanta causing power issues.
Incident Report for GSU Technology Systems
Resolved
Clarkston campus power was restored on Thursday-March 23rd. Please contact IIT Service Desk at 404-413-4357(HELP) or email help@gsu.edu to report any additional technical issues.
Posted Mar 24, 2017 - 12:19 EDT
Monitoring
The outage is being monitored.
Posted Mar 21, 2017 - 22:04 EDT
Identified
Due to inclement weather Clarkston campus is experiencing power issues. IIT staff is monitoring the situation and will provide updates as they are available.
Posted Mar 21, 2017 - 22:04 EDT