Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Telephone System Issues Reported
Incident Report for GSU Technology Systems
Resolved
This incident has been resolved.
Posted almost 3 years ago. Dec 04, 2013 - 01:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted almost 3 years ago. Dec 04, 2013 - 01:09 EDT
Investigating
IS&T is currently investigating reports of issues with the GSU Telephone System. Additional information will be posted here when the issue is confirmed.
Posted almost 3 years ago. Dec 04, 2013 - 00:58 EDT
This incident affected: Telephone System.