Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Telephone System Issue Reported
Incident Report for GSU Technology Systems
Resolved
Systems operating normally
Posted Dec 02, 2016 - 19:28 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2016 - 23:29 EST
Identified
II&T has identified an issue with intermittent inbound calls to a limited number of GSU Downtown campus direct phone numbers. We are currently working with our Service Provider to resolve this issue. Outbound calls from the downtown GSU campus are not affected at this time.

Please check back for updates.
Posted Nov 29, 2016 - 22:01 EST