Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Sign On Issues
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved issues logging into campus systems with Campus ID/Password credentials. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Sep 04, 2018 - 13:01 EDT
Update
Instructional Innovation and Technology (IIT) has implemented a fix and will continue to monitor. You should now be able to login to campus systems with Campus ID/Password credentials. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Aug 20, 2018 - 14:00 EDT
Monitoring
Instructional Innovation and Technology (IIT) has implemented a fix and will continue to monitor. You should now be able to login to campus systems with Campus ID/Password credentials. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Aug 20, 2018 - 13:56 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating sign on issues with certain single-sign-on (SSO) applications. Affected applications reported include ICollege, Paws, and Go-Solar. You may receive a "Service Temporarily Unavailable" error message. We will continue to provide updates as they become available.
Posted Aug 20, 2018 - 12:03 EDT
This incident affected: Brightspace/iCollege and GoSOLAR.