Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Downtown Atlanta Cisco Phones
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved Cisco phone issues on the Downtown Atlanta Campus. If you continue to experience issues please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted about 1 month ago. Sep 04, 2018 - 13:04 EDT
Monitoring
Instructional Innovation and Technology (IIT) has resolved Cisco phone issues on the Downtown Atlanta Campus. We will continue to monitor services. If you continue to experience issues please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted 2 months ago. Aug 09, 2018 - 19:40 EDT
Investigating
Instructional Innovation and Technology (IIT) has received reports of Cisco phones on the Downtown Atlanta Campus having issues making calls & receiving calls. We will post further information as it becomes available
Posted 2 months ago. Aug 09, 2018 - 17:29 EDT
This incident affected: Telephone System.