Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Website Issues Reported
Incident Report for GSU Technology Systems
Resolved
IIT has resolved issues reported about accessing GSU websites and its subdomains. Users should be able to successfully access GSU websites at this time. Please contact IIT Technology Service Desk at help@gsu.edu or contact 404-413-4357(HELP) to report any additional GSU website issues.
Posted Sep 19, 2017 - 15:55 EDT
Monitoring
Currently, IIT is monitoring GSU Websites and its subdomains. Users should be able to successfully access GSU websites at this time. Please contact IIT Technology Service Desk at help@gsu.edu or contact 404-413-4357(HELP) to report any additional GSU website issues.
Posted Sep 15, 2017 - 12:25 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with GSU Websites and its subdomains. Additional information will be posted here when the issue is confirmed.
Posted Sep 15, 2017 - 12:12 EDT