Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Non-person mailbox via Web access issue
Incident Report for GSU Technology Systems
Resolved
IIT was able to resolve issues reported with Outlook non-person mailbox via webaccess. Please contact IIT Technology Service Desk at 404-413-4357(HELP) and email help@gsu.edu to report any additional issues.
Posted Mar 29, 2017 - 07:45 EDT
Identified
Users may be unable to access shared (non-person) mailboxes in Outlook on the web.

Users will receive an error message that states: "The custom error module does not recognize this error." While we're focused on remediation, users may access shared mailboxes through the Outlook client. We are currently working with Microsoft to rectify the issue. While the change is being implemented, users may begin to experience the restoration of service.
Posted Mar 28, 2017 - 09:35 EDT