Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Office 365 (Fac/Staff Email) Issues Reported
Incident Report for GSU Technology Systems
Resolved
IS&T Engineers resolved the Office 365 web problem. Please contact IS&T Help Center by phone 404-413-4357(Help) or by email help@gsu.edu to report any problems
Posted Apr 09, 2014 - 12:40 EDT
Monitoring
IS&T Engineers resolved the Office 365 web problem. Faculty/Staff can now go to the webpage of outlook.com/gsu.edu to access their email on the web. IS&T will continue to monitor the issue throughout the rest of morning. Please contact IS&T Help Center by phone 404-413-4357(Help) or by email help@gsu.edu to report any problems.
Posted Apr 09, 2014 - 09:43 EDT
Investigating
IS&T is currently investigating reports of an issue with Office 365 (Fac/Staff Email). Users are not able to log onto web Office 365 email using campusid and password. Additional information will be posted here when the issue is confirmed.
Posted Apr 09, 2014 - 08:04 EDT