Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
WebEx Login Issues Reported
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved reports of login issues with WebEx. If you continue to experience issues, please contact the Help Desk at 404-413-4357 or email help@gsu.edu.
Posted 22 days ago. Oct 27, 2017 - 10:02 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of login issues with WebEx.
Additional information will be posted here when the issue is confirmed.
Posted 22 days ago. Oct 27, 2017 - 09:26 EDT