Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Network Issue - Decatur Campus
Incident Report for GSU Technology Systems
Resolved
Power has been restored to Decatur Campus. Network connectivity is now operational. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted Jul 19, 2018 - 12:39 EDT
Identified
Instructional Innovation and Technology (IIT) has identified a power outage in the "SA" building on Decatur Campus. Network and phone connectivity for the campus is impacted. We are awaiting ETA for restoration from Georgia Power. More information will be provided when available. If you have questions or concenrs, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted Jul 19, 2018 - 11:30 EDT