Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU webpages are not able to be accessed
Incident Report for GSU Technology Systems
Resolved
IS&T has been informed that the problem resulted from an issue with our Internet Service provider and that it has been resolved. The websites are now accessible. Please contact the IS&T Help Center at 404-413-4357 if you are still experiencing any further issues.
Posted over 2 years ago. Dec 20, 2013 - 13:02 EDT
Investigating
IS&T Help Center has been notified that certain webpages are not accessible including www.gsu.edu and technology.gsu.edu. Additional information will be posted here when the issue is confirmed.
Posted over 2 years ago. Dec 20, 2013 - 11:25 EDT
This incident affected: Brightspace/iCollege and University Website.