Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Student Email Creation
Incident Report for GSU Technology Systems
Resolved
IIT has resolved issues with email syncing. Both new and former students should now be able to access student email.If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted Apr 02, 2018 - 11:47 EDT
Monitoring
IIT has completed changes needed to correct the panthermail creation process. Over the weekend the email system will continue the account creation process. New students should be able to access panthermail accounts as early as Monday, March 26th. If you have questions or concerns, please contact the IIT Technology Service Desk at 404-413-4357(HELP) or email help@gsu.edu.
Posted Mar 23, 2018 - 18:22 EDT
Investigating
IIT has identified and is working to resolve an issue related to new student email accounts not currently being created. Updates will be provided here as they become available.
Posted Mar 21, 2018 - 12:24 EDT