Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Major Incident w/ Multiple Outages
Incident Report for GSU Technology Systems
Resolved
Disregard previous incident notification -
Posted Jul 18, 2016 - 09:57 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating widespread reports of multiple systems and services being unavailable, including [SYSTEM NAMES]. Additional information will be provided here when the issue is confirmed.
Posted Jul 18, 2016 - 09:54 EDT