Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
iCollege Issue Reported
Incident Report for GSU Technology Systems
Resolved
ICollege is functioning normally at this time. If you are still experiencing issues with ICollege, please contact the IIT Technology Service Desk to report any additional concerns by either emailing help@gsu.edu or calling 404-413-4357 (HELP).
Posted Sep 20, 2017 - 08:11 EDT
Monitoring
Functionality of ICollege has been restored. The University System of Georgia will continue to monitor the system for stability. If you are still experiencing issues with ICollege, please contact the IIT Technology Service Desk to report any additional concerns by either emailing help@gsu.edu or calling 404-413-4357 (HELP).
Posted Sep 19, 2017 - 08:31 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with iCollege. There are performance issues with iCollege which may affect a user’s ability to login or interact with the system. More information will be posted here as it becomes available.
Posted Sep 18, 2017 - 09:36 EDT