Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
PAWS Issues Reported
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved issues related to Paws. If you continue to experience issues, please contact the Help Desk at 404-413-4357(HELP) or email help@gsu.edu.
Posted 10 days ago. Jan 10, 2018 - 12:21 EST
Monitoring
Instructional Innovation and Technology (IIT) has resolved issues related to Paws. IIT will continue to monitor Paws performance. If you continue to experience issues, please contact the Help Desk at 404-413-4357(HELP) or email help@gsu.edu.
Posted 15 days ago. Jan 05, 2018 - 17:38 EST
Investigating
Instructional Innovation and Technology (IIT) is working to resolve issues with PAWS. Please logon directly to www.gosolar.gsu.edu for registration and payment functions if you are still experiencing issues in PAWS.
Posted 17 days ago. Jan 03, 2018 - 15:03 EST