Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
iCollege and PAWs log-in Issue Reported
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) resolved an error that users received when logging onto iCollege and PAWs. Please contact Service Desk to report any additional problems at 404-413-4357(HELP) or email help@gsu.edu.
Posted Jan 11, 2017 - 07:56 EST
Monitoring
Instructional Innovation and Technology (IIT) resolved an error that users received when logging onto iCollege and PAWs. Our team will continue to monitor the issue throughout the day. Please contact Service Desk to report any additional problems at 404-413-4357(HELP) or email help@gsu.edu.
Posted Jan 09, 2017 - 09:43 EST